<!– If your application uses Java 8 code, then the below two properties are required to tell maven use Java1.8 , otherwise
you gets compilation error as it uses default java 1.5 –>

<maven.compiler.source>1.8</maven.compiler.source>
<maven.compiler.target>1.8</maven.compiler.target>